Project

General

Profile

Bug #3697

MySQL Backend Programming Error: unknown type 9

Added by Anonymous almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
12/08/2014
Due date:
% Done:

0%

Estimated time:

Description

WT 3.3.4 latest Git code was used when this error was seen.

When attempting to access a legacy database table that has a id field defined as a mediumint(9), Wt::Dbo will generate an error.

MySQL Backend Programming Error: unknown type 9.

This appears to be caused by the fact that mysql is calling the mediumint a MYSQL_TYPE_INT24, which isn't defined in Wt/Dbo/backend/MySql.C

If desired to reproduce this issue, the legacy database being worked with that generated this error was the stock Bugzilla 4.4 database. The tables that were accessed to generate this error were "versions" and "milestones". Both these tables have mediumint(9) as the type for their primary key. mediumint(9) is actually a common type for the id fields in this database.

#1

Updated by Koen Deforche almost 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche

A patch is on its way.

#2

Updated by Koen Deforche over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF