Project

General

Profile

Bug #4977

jPlayer is obsolete

Added by Pau Garcia i Quiles over 5 years ago. Updated over 5 years ago.

Status:
New
Priority:
Low
Assignee:
-
Target version:
-
Start date:
06/14/2016
Due date:
% Done:

0%

Estimated time:

Description

Hello,

The jPlayer library has not been updated in two years. I have not found any active work. It never supported subtitles, and it seems it will never do.

The most complete alternative is VideoJS. It supports tracks (subtitles and captions), languages, covers, the skinning is pure CSS and there is an online skin designer, there are a ton of plugins and development is active. The biggest downside (other than the porting work itself) is the license: Apache 2.0, which is incompatible with the GPLv2.

What is the plan for the future?

#1

Updated by Koen Deforche over 5 years ago

It looks like videojs is indeed a good candidate for replacing it --- the license issue could be fixed from our side I guess.

#2

Updated by Pau Garcia i Quiles over 5 years ago

Fixing the license issue would require Wt to be relicensed as e. g. GPLv3

Also available in: Atom PDF