Project

General

Profile

Bug #5531

[Reg: 3.3.4 -> 3.3.6] Month combobox of WDateEdit is disabled in a secondary tab with progressive bootstrap enabled

Added by Kayra Akman almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/31/2017
Due date:
% Done:

0%

Estimated time:

Description

The month selection combobox of WDateEdit is disabled in the following scenario:

  • Add a WDateEdit to a tab of WTabWidget which isn't the default tab loaded.
  • Enable progressive bootstrap.
  • Load the application and switch to the secondary tab with disfunctioning WDateEdit.
  • Click the edit button of WDateEdit to open the calendar view. Month selection combobox is disabled but the rest of the widget functionality is available.

The attached application reproduces the issue.

Some observations:

  • A WDateEdit in the default tab (the tab shown when app is loaded, "tab 1" in the attached test app) works as expected.
  • If progressive bootstrap is disabled, WDateEdit works as expected.
  • The attached test application also has a WComboBox in "tab 2" which works as expected regardless of whether progressive bootstrap is enabled. So the issue is probably in WDateEdit not the embedded WComboBox.
  • The theme used doesn't affect the issue.

Files

dateedit_month_selection.cpp (1.51 KB) dateedit_month_selection.cpp Kayra Akman, 01/31/2017 01:48 PM
disabled_combobox.jpg (16.2 KB) disabled_combobox.jpg screenshot of test application Kayra Akman, 02/03/2017 08:46 PM
#2

Updated by Kayra Akman almost 5 years ago

An additional observation: If "tab 2" is added with WTabWidget::PreLoading than the WDateEdit functions as expected.

So, it seems that LazyLoading + Progressive Bootstrap harms WDateEdit.

#3

Updated by Roel Standaert almost 5 years ago

  • Status changed from New to InProgress
  • Assignee set to André Jacobs
#4

Updated by André Jacobs almost 5 years ago

  • Status changed from InProgress to Implemented @Emweb
#5

Updated by Roel Standaert almost 5 years ago

  • Status changed from Implemented @Emweb to Resolved
#6

Updated by Roel Standaert over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF