Project

General

Profile

Bug #5906

CMAKE_MINIMUM_REQUIRED version is too low.

Added by Harm ​ about 4 years ago.

Status:
New
Priority:
Low
Assignee:
-
Target version:
Start date:
09/08/2017
Due date:
% Done:

0%

Estimated time:

Description

Hi,

I know this a just a minor issue, but I was unable to build

Wt v3.3.8 with Debian Wheezy's stock CMake package (v2.8.9).

The te-benchmark example that was added between v3.3.7 and v3.3.8 seems to be the culprit, see document:"CMake log with version 2.8.10.2 (fails)".

I tested a few newer CMake versions and came to the conclusion that v2.8.11 is now the

minimum required CMake version to build Wt v3.3.8, see document:"CMake log with version 2.8.11 (success)".

If CMAKE_MINIMUM_REQUIRED(VERSION 2.4)

could be changed to CMAKE_MINIMUM_REQUIRED(VERSION 2.8.11),

users with an older version will get a clear and helpful message that their CMake is outdated:

# cmake ..
CMake Error at CMakeLists.txt:1 (CMAKE_MINIMUM_REQUIRED):
  CMake 2.8.11 or higher is required.  You are running version 2.8.9

Thanks,

Harm.


Files

v2.8.10.2 Fail.txt (12.3 KB) v2.8.10.2 Fail.txt CMake log with version 2.8.10.2 (fails) Harm ​, 09/08/2017 12:05 PM
v2.8.11 Success.txt (15.2 KB) v2.8.11 Success.txt CMake log with version 2.8.11 (success) Harm ​, 09/08/2017 12:05 PM

No data to display

Also available in: Atom PDF