Project

General

Profile

Bug #724

Shadow areas on CartesianChart with Chrome

Added by Christophe Delépine almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/15/2011
Due date:
% Done:

0%

Estimated time:

Description

Hi,

I have just tried my Wt application using Chrome.

I can see shadow areas on the cartesian charts. Their shape changes when i edit the curve by adding new points

It works fine with Firefox.

Is that a known bug with Chrome ?

Regards

Christophe


Files

gui_chrome.jpg (280 KB) gui_chrome.jpg Christophe Delépine, 02/15/2011 04:53 PM
CurveEdit.cpp (7.78 KB) CurveEdit.cpp Christophe Delépine, 02/16/2011 02:12 PM
CurveEdit.h (1.36 KB) CurveEdit.h Christophe Delépine, 02/16/2011 02:12 PM
#1

Updated by Koen Deforche almost 11 years ago

Hey Christophe,

No, that's new to me. Chrome always behaved well as far as my experience goes. Is the image rendered as an SVG or as canvas ?

And any idea what you are doing different than the charts example, which does not show this artefact for me ?

Regards,

koen

#2

Updated by Christophe Delépine almost 11 years ago

Koen,

Here is the source code for my curve editor. The main setup is in the class constructor.

I don't have the feeling i do anything special

I have 2 series : one is drawn with green line segments + yellow markers. The second series is empty and only contains data when the user selects a marker.

Regards

Christophe

#3

Updated by Christophe Delépine almost 11 years ago

The problem comes from the following line :

    s.setShadow(WShadow(3, 3, WColor(0, 0, 0, 127), 2));

If i remove this line, then the shadow areas disappear. Looks like the shadow is not well managed on Chrome

#4

Updated by Koen Deforche over 10 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche

Hey Christophe,

I could reproduce this. Apparently it happens when SVG is used, and the bug is known and open in Chromium:

http://code.google.com/p/chromium/issues/detail?id=71773

I suggest that you use HTML5 Canvas for rendering the chart?

Regards,

koen

#5

Updated by Christophe Delépine over 10 years ago

Hi Koen,

You can close bug#724 since the problem is within Chrome.

FYI, i have tried setPreferredMethod(HtmlCanvas) for my chart but the bug still occurs. This is with the latest Chrome.

I have desactivated shadows for the moment.

Regards

Christophe

#6

Updated by Koen Deforche over 10 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF