Project

General

Profile

Bug #891

Use std::size_t for rowCount() and columnCount() values.

Added by Anonymous over 10 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
07/07/2011
Due date:
% Done:

0%

Estimated time:

Description

This aids in 64bit portability when mixing with the Standard C libraries and STL. It removes the need to use static_cast< int > all over the place to avoid compiler wanings.

Could even follow the standard convention of using the size_type class typedef.

#1

Updated by Mark Snelling over 10 years ago

Sorry, didn't mean to post this as anonymous.

#2

Updated by Koen Deforche over 10 years ago

  • Status changed from New to Feedback
  • Assignee set to Koen Deforche

Hey,

The discussion of int versus unsigned, and by expansion std::size_type, is indeed not trivial, but the problem is that we cannot simply change this now (since this breaks custom model implementations).

If we would be able to break (or do this change without breaking ?) then, probably yes I would be inclined to follow here more STL-conventions (versus Qt-conventions).

Regards,

koen

#3

Updated by Koen Deforche over 8 years ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF