Project

General

Profile

Support #1207

WTreeView + mouseWentUp

Added by Max Quatember over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
03/21/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi!

Is there a possibility to handle the mouseWentUp message in an empty WTreeView?

To show a custom WPopupMenu for example...

Best regards,

Max


Files

test.cpp (1.03 KB) test.cpp Max Quatember, 01/30/2013 08:58 AM
#1

Updated by Koen Deforche over 8 years ago

  • Status changed from New to InProgress
  • Assignee set to Koen Deforche
  • Target version set to 3.2.2

Hey,

I see no problem in providing this.

Regards,

koen

#2

Updated by Max Quatember over 8 years ago

Yeah! Cool!

#3

Updated by Koen Deforche over 8 years ago

  • Status changed from InProgress to Closed

Implemented in 3.2.2

#4

Updated by Max Quatember over 7 years ago

hi koen!

this is not working for me with 3.2.3.

i cannot say if it's an regression, because i skipped 3.2.2.

problem exists with treeview + tableview

please see attached testcase...

best regards,

max

#5

Updated by Koen Deforche over 7 years ago

  • Status changed from Closed to InProgress
  • Assignee changed from Koen Deforche to Pieter Verberck
  • Target version changed from 3.2.2 to 3.3.0

Pieter,

Can you see if you can reproduce and diagnose this problem ?

koen

#6

Updated by Koen Deforche over 7 years ago

  • Assignee changed from Pieter Verberck to Koen Deforche

We can't locate the feature, we can only implement it twice ? :-)

#7

Updated by Max Quatember over 7 years ago

hi koen!

would be nice if you could implement it once more ;-)

when to you approximately plan to release a new version?

especially bugfixes for #1647, #1651 and of course #1207 would be very helpful for us...

thanks in advance!

best regards,

max

#8

Updated by Koen Deforche over 7 years ago

Hey Max,

We would like to have a first release candidate by the end of the week, and those issues will be covered (I suspect some of them have been fixed as side-effect of other reorganizations, but I need to still test).

Regards,

koen

#9

Updated by Max Quatember over 7 years ago

Hi Koen!

Great to hear!

I'm ready for testing! If you need something from me, just tell.

best regards,

Max

#10

Updated by Koen Deforche over 7 years ago

  • Status changed from InProgress to Resolved

Hey Max,

You'll see it coming. I did it both for WTreeView and WTableView (your bug report wasn't entirely unambiguous ;-) )

koen

#11

Updated by Koen Deforche over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF