Project

General

Profile

Bug #2257

Crash in WDialog destructor at session termination

Added by Will Johnson about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
09/27/2013
Due date:
% Done:

0%

Estimated time:

Description

If a non-modal WDialog is destructed as part of the domRoot at session termination, then a crash can occur.

Specifically, in the DialogCover constructor called by WDialog::cover() function, the new DialogCover will be added to a WApplication::domRoot() which is now invalid since it is being deleted.

Attached is some code that will recreate this issue. To reproduce: using the httpd connector, start the attached app and load it in a browser tab; close the tab, and then a while later try to load a new instance of it, and when the old original session gets cleaned up, the process will crash.

I have had this issue on Wt 3.3.1-rc1 and the git version from a couple days ago.


Files

main.cpp (2.71 KB) main.cpp Simple app to seemingly reliably reproduce issue. Will Johnson, 09/28/2013 12:03 AM
#1

Updated by Koen Deforche about 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Koen Deforche

Hey,

Thanks! It almost slipped into 3.3.1!

Regards,

koen

#2

Updated by Koen Deforche about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF