Project

General

Profile

Bug #4464

instability with dedicated-process whttpd server configuration

Added by mat Sch about 6 years ago. Updated about 6 years ago.

Status:
Feedback
Priority:
High
Assignee:
-
Target version:
-
Start date:
09/09/2015
Due date:
% Done:

0%

Estimated time:

Description

I'm running a server that's handling about 40 clients with traffic constantly going back and forth between server and client. I'm running stock 3.3.4 code. Every 3-5 days i'm seeing the server process core dump with an assertion in boost. top 5 stacks of backtrace below. What makes this worse is after it backtraces it takes about 5 minutes before the server process is able to start again. Not sure why that is, but I assume a socket is open or something.

Note that the running code does not have the code for bug fix #4417(whttp connector and max-num-sessions not working).

#0 0xb42d0556 in raise () from /lib/libc.so.6

#1 0xb42d1d78 in abort () from /lib/libc.so.6

#2 0xb42c9590 in __assert_fail () from /lib/libc.so.6

#3 0xb6525325 in http::server::ProxyReply::writeDone (this=0xabe03a50, success=true)

at /usr/local/include/boost/smart_ptr/shared_ptr.hpp:418

#4 0xb6514ed9 in http::server::Connection::handleWriteResponse (this=0x93af660, reply=

{px = 0xaf249ef0, pn = {pi_ = 0xaf249ea8}}, e=@0xaf249ee4, bytes_transferred=512)

at /home/root/src/hyas/2.5/3rdparty/wt-3.3.4snap/src/http/Connection.C:420

#5 0xb6575122 in boost_asio_handler_invoke_helpers::invoke<boost::asio::detail::binder2<boost::_bi::bind_t<void, boost::_mfi::mf3<void, http::server::Connection, boost::shared_ptrhttp::server::Reply, boost::system::error_code const&, unsigned int>, boost::_bi::list4<boost::_bi::value<boost::shared_ptrhttp::server::TcpConnection >, boost::_bi::value<boost::shared_ptrhttp::server::Reply >, boost::arg<1> ()(), boost::arg<2> ()()> >, boost::system::error_code, unsigned int>, boost::asio::detail::binder2<boost::_bi::bind_t<void, boost::_mfi::mf3<void, http::server::Connection, boost::shared_ptrhttp::server::Reply, boost::system::error_code const&, unsigned int>, boost::_bi::list4<boost::_bi::value<boost::shared_ptrhttp::server::TcpConnection >, boost::_bi::value<boost::shared_ptrhttp::server::Reply >, boost::arg<1> ()(), boost::arg<2> ()()> >, boost::system::error_code, unsigned int> > (function=@0xaf249f80

#1

Updated by Koen Deforche about 6 years ago

  • Status changed from New to Feedback

Hey,

It would be interesting to know if current git (which will become Wt-3.3.5-rc1) solves these issue. Several things got fixed in recent months.

Koen

Also available in: Atom PDF