Project

General

Profile

Bug #4769

Compile error in src/http/RequestParser.C

Added by Saif Rehman almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
02/26/2016
Due date:
% Done:

0%

Estimated time:

Description

I'm compiling with SHARED_LIBS on and using wthttp connected. I get the compile error in src/http/RequestParser.C:

\src\http\RequestParser.C(68): error C2614: 'http::server::RequestParser': illegal member initialization: 'inflateInitialized_' is not a base or member
#1

Updated by Koen Deforche almost 7 years ago

  • Status changed from New to InProgress
  • Assignee set to Benoit Daccache
#2

Updated by Saif Rehman almost 7 years ago

The preprocessor condition was missing in the constructor of RequestParser

Should be

RequestParser::RequestParser(Server *)
#ifdef WTHTTP_WITH_ZLIB
  : inflateInitialized_(false)
#endif
{
  reset();
}
#3

Updated by Koen Deforche almost 7 years ago

  • Status changed from InProgress to Feedback
  • Assignee changed from Benoit Daccache to Saif Rehman

Did you intend to build wt without zlib support or is there something wrong with the defaults chosen by CMake?

#4

Updated by Saif Rehman almost 7 years ago

I built Wt without zlib and the preprocessor condition was missing

#5

Updated by Saif Rehman almost 7 years ago

There is still a problem in RequestParser.C, the problem is that the constructor's initializer : is not enclosed in the preprocessor condition

#6

Updated by Wim Dumon almost 7 years ago

  • Status changed from Feedback to Resolved

Fixed

#7

Updated by Koen Deforche over 6 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.3.6

Also available in: Atom PDF